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HZV HPMnext FAQ für den Support

Problem:

Bei manuellen Änderungen an der kommunikation.ini mit dem Windows-Editor (Notpad) wird beim Speichern der falsche Zeichensatz, "UTF-8 BOM" statt "UTF-8", hinterlegt und die kommunikation.ini kann nicht mehr korrekt ausgelesen werden.

Bisher bekannte Betriebssysteme: Windows Server 2019, Windows Server 2016 Fehlerbild: Bei Aufruf von IHZV wird immer der Name "hzvbox" ausgelesen, statt der entsprechenden IP oder des korrekten Rechnernamens:

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Ursache: Öffnet man die kommunikation.ini im …medistar\inst-Verzeichnis mit Notpad sieht der Eintrag erstmal normal aus, die Sonderzeichen für den UTF-8 BOM - Zeichensatz sind dort nicht erkennbar:

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Um das Problem sehen und beheben zu können, muss ein geeigneter Editor, z.B. notepad ++, verwendet werden. Wenn man sich die Datei mit einem notpad++-Editor ansieht, wird der falsche Zeichensatz unten rechts angezeigt, siehe folgender Screen

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Außerdem ist es möglich, sich die Sonderzeichen mit einem Hex-Editor anzeigen zu lassen, dann sieht das so aus. Das ist aber nicht zwingend erforderlich. Es ist nur ein Beispiel, um zu sehen, was dort genau durch den falschen Zeichensatz eingefügt wurde:

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Lösung:

Zum Umstellen des Zeichensatzes kann man im notpad++ auf den Eintrag unten rechts einen Doppelklick ausführen und erhält dann folgende Liste (siehe Screen). Hier einfach den Zeichensatz "UTF-8" ohne BOM auswählen und im Anschluss die Datei so speichern.

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Den MEDISTAR-Task neu starten und erneut eine Verbindungsprüfung über IHZV durchführen, jetzt sollte die korrekte IP oder der korrekte Name der Maschine, auf der das HÄVG-Prüfmodul installiert wurde, angezeigt werden, wie z.B. im folgenden Screenshot:

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Wenn ihr die Anpassung nicht auf dem Rechner des Anwenders durchführen wollt oder könnt, holt euch die Datei auf euren eigenen Rechner und führt dort die Änderung durch. Im Anschluss einfach wieder auf den Kundenrechner unter …\medistar\inst kopieren.

Alternativer Lösungsansatz (bitte nur, wenn es gar nicht anders geht, verwenden):

Wenn nichts anderes als der Windows-Editor zur Verfügung steht, weil z.B. der Download eines alternativen Editors in der Praxis nicht funktioniert oder ihr keine Zeit habt, die Datei zu euch zu holen und lokal zu bearbeiten oder gar die Fernwartungssoftware nicht funktioniert, fügt in der kommunikation.ini einfach eine Leerzeile bzw. einen Zeilenumbruch in die erste Zeile der Datei ein. Dann wird die Datei zwar trotzdem im "falschen" UTF8 BOM-Format gespeichert, jedoch kann so die Zeile mit der Sektion [HZV-BOX] korrekt ausgelesen werden, siehe folgender Screenshot:

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Es wird der HaCoreHost=7800 aus der kommunikation.ini geprüft.
Fehlerbild: In IHZV wird bei Prüfung der Konnektivität über "Erreichbarkeit prüfen" folgende Fehlermeldung angezeigt:

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Ursache: Folgender Eintrag in der kommunikation.ini führt zu dieser Fehlermeldung:

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Lösung:

Unter Beachtung des unter 1. genannten Problems (!!!) mit dem Zeichensatz die Zeile mit dem "HaCorePort=7800" aus der kommunikation.ini entfernen.

 

 

Die Online-Teilnahmeprüfung zeigt einen Requestfehler an.
Fehlerbild: Beim Ausführen der Onlineteilnahmeprüfung erscheint folgende Fehlermeldung

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oder:

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Ursache:

Die Meldung kann an jedem Platz erscheinen (Server oder Workstation). Der Fehler wird ausgelöst, wenn die Uhrzeit an dem Rechner von dem aus die Anfrage gestellt wird, von der Uhrzeit auf dem Empfängersystem abweicht. Das Empfängersystem besteht aus den Servern der HÄVG. Es gibt eine Zeittoleranz von ca. 10 Minten, in dem Rahmen darf sich die Uhrzeit maximal an dem jeweiligen Rechner zur HÄVG-Serveruhrzeit unterscheiden.

 

Lösung:

Datum und Uhrzeit am Praxisrechner (Server oder Workstation) auf die aktuelle Zeit anpassen. Der Aufruf des Einstellungsdialoges ist vom Betriebssystem abhängig.

Im Folgenden ein Bsp. dazu. Einfache über die Betriebssystemsuche nach "Datum…" suchen und die Einstellungen dafür auswählen

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